Linux support and QT version

Post Reply
Doranwen
Posts: 2
Joined: Sat 16. Jan 2021, 07:38

Linux support and QT version

Post by Doranwen » Sat 16. Jan 2021, 07:53

I'm not sure whether this belongs in bugs and problems or feature request, as it's kind of a bit of both. I've been a long-time user of FFDL on Linux and have found it very useful, particularly when I wanted to download only specific chapters of AO3 fics (:p to authors who create "fics" where every chapter's a different fandom ficlet!), as other fanfic downloaders didn't seem to offer that. But when it failed to work and I went to get the newest version, I was dismayed at the requirements.

The Linux version specifically requires QT 5.15, as stated on the website (and indeed the terminal will complain if one tries to run a version that is lower). However, for both Ubuntu and Mint, the latest stable versions of QT on each only go to 5.12. Mint (which is my native distro) doesn't have a newer less-stable version (it tends to be based off LTS releases only), so it's not even possible to upgrade to a version that can run FFDL. I would have to install the latest version of Ubuntu (a version that's only supported through July of this year) in a VM just to run FFDL! (While I do have some already-existing Windows VMs, they're older versions and don't have the service packs necessary to run the Windows version of FFDL, and I'm not sure that installing it with Wine on my Linux system would work all that well - but correct me if I'm wrong!)

Is there any way that the requirement for 5.15 can be lowered to an earlier version of Qt5 so that those of us on Long Term Support releases aren't unable to use FFDL without resorting to VMs for a different distro? I would be extremely grateful, and I'm sure I wouldn't be alone.

EDIT: I double-checked; the latest version of Ubuntu only goes to 5.14. When I asked for help on the Mint forums to find a way to upgrade, they said that it must have been compiled with KDE Neon Dev Stable instead of Kubuntu or Ubuntu, because the framework releases are generally even numbers; odd numbers are development builds. Is there a serious reason why this requires a development build (something few Linux users are likely to be running) or is it possible to downgrade the requirement to, say, 5.12, so that all the latest stable distros can run it?

Chrystalline
Posts: 3
Joined: Wed 22. Jul 2015, 02:01
Contact:

Re: Linux support and QT version

Post by Chrystalline » Sun 17. Jan 2021, 22:06

Seconding that. (with less understanding, but still.)

From what I was able to determine, after 5.14 the QT isn't available except as code, to be custom-compiled by the user. As a total newbie with Linux, I found that too daunting and gave up and went back to Win7 for FFDL. I hadn't wanted to do that - for Windows, I've been trying to go completely portable so I can switch back and forth between Win7 and Win10 with my portable hard drive.

Win10 made me crazy enough to set up my Win7 laptop to dual-boot with Zorin, but Linux is an adventure in every possible connotation. I may have misunderstood what QT.io was saying, and if so, I am eager to be instructed, but that was my take-away. I'd post the links, but I'm on the Win10 laptop today and I can't find them again. The site keeps re-routing me to Windows files, and all my bookmarks are in the browser in Linux.

Is there a way to include the QT 5.15 with FFDL? Or perhaps a guide to compile/install it that doesn't expect us to be programmers? QT.io seems to think the only reason to download QT is to write programs, so it's frustrating for a non-coder like me to not have a simple way to get the prerequisites for the program I actually want.

Doranwen
Posts: 2
Joined: Sat 16. Jan 2021, 07:38

Re: Linux support and QT version

Post by Doranwen » Wed 27. Jan 2021, 23:30

Chrystalline wrote:
Sun 17. Jan 2021, 22:06
Is there a way to include the QT 5.15 with FFDL?
I think that would be possible if the programmer released it as a Flatpak or Snap or AppImage (I think those are the ones out there)? I would LOVE for that option to be available! It would be lovely to just install it that way and not have to worry about upgrades.

But I would love more to just be able to use it in my Linux computer again. I managed to start up an old Win7 desktop that I had lying around and that worked to run it on, but it's an awful pain to have to send all the links over there, download them, upload the files to a shared folder, and then pull them down on my regular computer! Even being able to run it in a VM would be preferable, but again, none of the Linux distros out there *has* Qt 5.15 that I know of, so it's a little ridiculous to expect all the Linux users to install that before running it.

Qt affects so many programs on Linux that upgrading the whole thing for one program is a very risky maneuver (I could very easily cause issues with another program, or worse, bork the entire install and cause half my programs to be unusable). And I can't imagine that 5.15 has specific options available that were so essential that it was absolutely necessary for the program to require that precise version, rather than accepting 5.12 or something more sane, lol. So I'm very puzzled by that choice.

Post Reply